4.67 of 5 - 6 votes
Thank you for rating this article.

Joomla 4 w wersji beta 1 już jest !

Joomla 4

Co nowego w Joomla 4 ?

 

Właśnie opublikowano najnowszą wersję Joomla 4, tym razem jest to pierwsza wersja beta  . Jest to o tyle ważna i dobra wiadomość, bo zgodnie z planem projektu , wersja beta planowana była na marzec 2020. 

Należy zatem spodziewać się premiery Jooma! 4 już w tym roku. Zanim pojawi się wersja finalna, poniżej przedstawiamy kilka funkcji nowego Joomla!4:

  • Przede wszystkim, zmieniono proces instalacyjny, który teraz jest dużo łatwiejszy i błyskawiczny.
  • Nowe zmienione, bardziej intuicyjne interfejsy użytkownika, dla Zaplecza i Witryny.
  • Zaimplementowany standard WCAG 2.1 (AA), który sprawi, że strony z Joomla4, będą dostępne dla osób z niesprawnościami, tuż po instalacji.
  • W celu szybszego ładowania oraz uniknięcia potencjalnych konfliktów bibliotek, usunięto z kodu Joomla4, jQuery.
  • Przebudowany komponent mediów, który pozwoli na edycję zdjęć oraz korzystanie z zasobów w chmurze.
  • Stylizacja Joomla4 oparta jest na najnowczym Bootstrap 4, to dobra wiadomość, ale zmiana ta przyniesie konieczność zmian w dotychczasowych szablonach i rozszerzeniach, które korzystały z wcześniejszych wersji Bootstrap.
  • Poprawione bezpieczeństwo - Nowe zabezpieczenia takie jak Przygotowane instrukcje SQL
  • Dzięki obsłudze HTML, będzie można w pełni dostosować szablon i wygląd wiadomości wysyłanych przez naszą stronę do użytkowników.
  • Nowy konfigurowalny system przepływu treści (workflow) podczas ich tworzenia.
  • Dla programistów możliwość korzystania z Web Serwisów
  • Zintegrowany Joomla Framework z CMS'em
  • poprawiona i rozszerzona funkcjonalność Linii Poleceń (CLI)

 Joomla4 i kilka interfejsów:

Joomla 4 administrator1 Joomla 4 administrator2 Joomla 4 administrator3 Joomla 4 component Joomla 4 content Joomla 4 users Joomla 4 media Joomla 4 system

Joomla 4 - wymagania techniczne

  • PHP 7.2
  • MySQL 5.6 (uwaga: minimalna wersja MySQL może ulec zmianie jeśli zajdzie taka potrzeba, w trakcie eksploatacji Joomla 4 )
  • PostgreSQL 11.0
  • Minimalna wersja dla przeglądarek to n-2
  • Koniec wsparcia dla Internet Explorer'a

 

Komentarze obsługiwane przez CComment